Softcloseproblem.

S-klass generation 3, tillverkades mellan 1991-1999.
Lasse Bender
Expert
Expert
Posts: 591
Joined: Sun 22 Nov, 2009 22:10
Location: Beddingestrand

Softcloseproblem.

Postby Lasse Bender » Tue 21 Apr, 2020 16:15

Bytte softclosepumpen eftersom motorn i den gamla plötsligt gav upp. Inga problem med någon dörr innan bytet men nu händer det ständigt att en dörr inte fungerar, och samma dörr hela tiden. När jag drar säkringen i skuffen funkar det igen, ett tag. Pumpen kan jag utesluta eftersom den är ny. Läcka?
Men att det skulle läcka nu när det inte gjorde det innan med den gamla pumpen verkar lite konstigt. Och varför funkar det efter jag drar säkringen. Innan jag river bort allt igen skulle jag gärna vilja veta vad jag skall söka efter. Några friska idéer efterlyses, tack!

User avatar
Marie
Guru
Guru
Posts: 6871
Joined: Fri 27 Jun, 2008 11:38
Location: Obervellach bei Hermagor / Kinna

Re: Softcloseproblem.

Postby Marie » Tue 21 Apr, 2020 22:27

Lasse Bender wrote:Bytte softclosepumpen eftersom motorn i den gamla plötsligt gav upp. Inga problem med någon dörr innan bytet men nu händer det ständigt att en dörr inte fungerar, och samma dörr hela tiden. När jag drar säkringen i skuffen funkar det igen, ett tag. Pumpen kan jag utesluta eftersom den är ny. Läcka?
Men att det skulle läcka nu när det inte gjorde det innan med den gamla pumpen verkar lite konstigt. Och varför funkar det efter jag drar säkringen. Innan jag river bort allt igen skulle jag gärna vilja veta vad jag skall söka efter. Några friska idéer efterlyses, tack!


Du har något problem med just den dörrens tryckluftskrets. Antagligen ett mindre läckage i softcloseelementet i låset, eller ledningen dit från pumpen.
I själva softclosepumpen finns en övervakning som kollar att rätt tryck uppnås inom en viss tid (jag har för mig att det är 10s). Om det finns en läcka uppnås inte trycket i tid och ett fel lagras i pumpens dator. Om samma krets (dörr) får felnotering fem gånger (jag har för mig att det är det antalet) så stängs den kretsen av för att inte pumpen skall överbelastas. Genom att dra säkringen raderar du felminnet och allt funkar igen tills antalet fel ånyo uppnåtts. Detta är principen.

Det förinställda trycket från fabrik är vanligtvis onödigt högt. För att skona pumpen (och slippa onödiga felnoteringar) är det många som justerar ned trycket, så att man klarar att stänga dörrarna, men inte mycket mer. film om detta finns på Youtube.

Antingen har någon tidigare ägare gjort detta med din gamla pump, så att (det lägre) trycket uppnås inom tidsgränsen trots ett smärre läckage,
ELLER så har du inte fått aktuell dörrs tryckluftskrets riktigt tät när du skiftade pump. Det är i princip de enda möjligheterna jag ser till att problemet tog sin början vid pumpbytet.

Personligen tror jag mest på att du inte fick anslutningen för aktuell dörr riktigt tät när när du monterade anslutningen på den nya pumpen.

Lösningsförslag:
1) Kolla den aktuella dörrens tryckluftskrets med avseende på läckage, och åtgärda läckaget. Detta är den korrekta och ortodoxa åtgärden.

2) Sänk erforderligt tryck genom att justera tyckströmbrytaren som finns inuti pumpen. Eftersom brytarens justerskruv är säkrad med plomberingslack är den åtgärden inte att rekommendera på en pump som har reservdelsgaranti från Mercedes.

Eftersom min nuvarande pump är köpt begagnad och definitivt garantifri har jag för att skona pumpen justerat ned trycket så att alla dörrar orkar dras i lås, men inte mer heller. Tryckbrytaren slår ifrån nån enstaka sekund efter att dörren gått i lås. Jag har till och med borrat ett hål i pumpens hölje så att jag kommer åt justerskruven med en skruvmejsel utan att öppna pumpen.
MB 400SE -92Image
BMW K100RS -85

Ex: MB 200TE -90 (ärvde det rostiga liket 2012)
MB 300SEL -89 (exporterad till Stockholm)
MB 300D Lang -86 (hittade en älg)
MB 200 -85 (smälld av tredje sonen)
MB 240D -80 (rostade bort)

Lasse Bender
Expert
Expert
Posts: 591
Joined: Sun 22 Nov, 2009 22:10
Location: Beddingestrand

Re: Softcloseproblem.

Postby Lasse Bender » Wed 22 Apr, 2020 10:44

Marie wrote:
Lasse Bender wrote:Bytte softclosepumpen eftersom motorn i den gamla plötsligt gav upp. Inga problem med någon dörr innan bytet men nu händer det ständigt att en dörr inte fungerar, och samma dörr hela tiden. När jag drar säkringen i skuffen funkar det igen, ett tag. Pumpen kan jag utesluta eftersom den är ny. Läcka?
Men att det skulle läcka nu när det inte gjorde det innan med den gamla pumpen verkar lite konstigt. Och varför funkar det efter jag drar säkringen. Innan jag river bort allt igen skulle jag gärna vilja veta vad jag skall söka efter. Några friska idéer efterlyses, tack!


Du har något problem med just den dörrens tryckluftskrets. Antagligen ett mindre läckage i softcloseelementet i låset, eller ledningen dit från pumpen.
I själva softclosepumpen finns en övervakning som kollar att rätt tryck uppnås inom en viss tid (jag har för mig att det är 10s). Om det finns en läcka uppnås inte trycket i tid och ett fel lagras i pumpens dator. Om samma krets (dörr) får felnotering fem gånger (jag har för mig att det är det antalet) så stängs den kretsen av för att inte pumpen skall överbelastas. Genom att dra säkringen raderar du felminnet och allt funkar igen tills antalet fel ånyo uppnåtts. Detta är principen.

Det förinställda trycket från fabrik är vanligtvis onödigt högt. För att skona pumpen (och slippa onödiga felnoteringar) är det många som justerar ned trycket, så att man klarar att stänga dörrarna, men inte mycket mer. film om detta finns på Youtube.

Antingen har någon tidigare ägare gjort detta med din gamla pump, så att (det lägre) trycket uppnås inom tidsgränsen trots ett smärre läckage,
ELLER så har du inte fått aktuell dörrs tryckluftskrets riktigt tät när du skiftade pump. Det är i princip de enda möjligheterna jag ser till att problemet tog sin början vid pumpbytet.

Personligen tror jag mest på att du inte fick anslutningen för aktuell dörr riktigt tät när när du monterade anslutningen på den nya pumpen.

Lösningsförslag:
1) Kolla den aktuella dörrens tryckluftskrets med avseende på läckage, och åtgärda läckaget. Detta är den korrekta och ortodoxa åtgärden.

2) Sänk erforderligt tryck genom att justera tyckströmbrytaren som finns inuti pumpen. Eftersom brytarens justerskruv är säkrad med plomberingslack är den åtgärden inte att rekommendera på en pump som har reservdelsgaranti från Mercedes.

Eftersom min nuvarande pump är köpt begagnad och definitivt garantifri har jag för att skona pumpen justerat ned trycket så att alla dörrar orkar dras i lås, men inte mer heller. Tryckbrytaren slår ifrån nån enstaka sekund efter att dörren gått i lås. Jag har till och med borrat ett hål i pumpens hölje så att jag kommer åt justerskruven med en skruvmejsel utan att öppna pumpen.


Tack för ditt svar Marie! Då är vi inne på samma tankegångar. Utesluter pumpen och även att det skulle vara lokaliserat till dörrlåset eftersom det funkade med den gamla. Tror också på att det har blivit ett läckage vid anslutningen till pumpen på just den kretsen. Irriterande är det eftersom det är förardörren. Kan då möjligen bero på att en slang har blivit lite för hårt vinklad vid pumpåtermonteringen och därmed bryter i anslutningen.

Dock tycker mig inte kunna höra att pumpen går onormalt länge vid stängning av dörren vilket den då borde göra. Har för mig att den skall gå c:a 3 sek? och det är nog vad den gör också. Jag går på åtgärd !. Plocka ut den och låta den ligga löst ett tag för att se om det blir någon skillnad. Att ge mig på en ny pump är uteslutet.Tack Marie!

User avatar
Marie
Guru
Guru
Posts: 6871
Joined: Fri 27 Jun, 2008 11:38
Location: Obervellach bei Hermagor / Kinna

Re: Softcloseproblem.

Postby Marie » Wed 22 Apr, 2020 21:07

En pump till verkar överkurs. Rent teoretiskt KAN det vara en läcka inuti pumpen på den kretsen. Men i min värld känns det osannolikt.

Det man i sista hand kan göra är ju att växla tryckledning och signalkablar med en annan dörr. Då ser man ju om felet flyttar med....
MB 400SE -92Image
BMW K100RS -85

Ex: MB 200TE -90 (ärvde det rostiga liket 2012)
MB 300SEL -89 (exporterad till Stockholm)
MB 300D Lang -86 (hittade en älg)
MB 200 -85 (smälld av tredje sonen)
MB 240D -80 (rostade bort)

Lasse Bender
Expert
Expert
Posts: 591
Joined: Sun 22 Nov, 2009 22:10
Location: Beddingestrand

Re: Softcloseproblem.

Postby Lasse Bender » Fri 24 Apr, 2020 16:22

Uttryckte mig slarvigt. Att ge mig på att öppna pumpen finns förstås inte på kartan eftersom den är ny och med garanti, det var det jag ville säga.

Tror att jag har lokaliserat felet.
Pumparna är inte exakt identiska, original satt där en Hella och den nya är en Bosch. Boschpumpen är c:a 5 mm högre och 5 mm bredare vilket gör att det är ett litet h-e att få in den på plats. Dessutom visar det sig att anslutningsnipplarna på pumparna är olika utformade vilket gör att de inte håller helt tätt på den nya. Man hör tydligt att det läcker luft vid anslutningarna när pumpen går och om man trycker på dom så blir det tyst. Problemet flyttade runt mellan dörrarna när jag hade plockat ut den.

Hur man löser detta har jag ingen aning om men jag får ta snacket med Mercedes.

User avatar
Marie
Guru
Guru
Posts: 6871
Joined: Fri 27 Jun, 2008 11:38
Location: Obervellach bei Hermagor / Kinna

Re: Softcloseproblem.

Postby Marie » Sat 25 Apr, 2020 03:07

Prima!
Ja jag tror också att du funnit problemet. Jag vet faktiskt inte om anslutningarna är olika mellan Hella och Bosch, och jag har inte haft anledning att fördjupa mig i den frågan heller, eftersom originalpumpen i bilen var en Bosch, den jag köpte beg för elva år sedan då originalet gav upp andan var också Bosch, och den fabriksnya, som ligger på hyllan i mitt ganska omfattande reservdelslager, är även den en Bosch.
Eventuellt får det undersökas om slangarnas anslutningar finns lösa som reservdel, och i så fall får de gamla Hellaanslutningarna skäras loss från slangarna och nya Boschanslutningar limmas dit.

Att ha otäta anslutningar är utöver olägenheten att behöva resetta pumpen genom att dra säkringen, också mycket olämpligt eftersom den nya pumpen då icke blir långlivad...
MB 400SE -92Image
BMW K100RS -85

Ex: MB 200TE -90 (ärvde det rostiga liket 2012)
MB 300SEL -89 (exporterad till Stockholm)
MB 300D Lang -86 (hittade en älg)
MB 200 -85 (smälld av tredje sonen)
MB 240D -80 (rostade bort)

Lasse Bender
Expert
Expert
Posts: 591
Joined: Sun 22 Nov, 2009 22:10
Location: Beddingestrand

Re: Softcloseproblem.

Postby Lasse Bender » Fri 22 Sep, 2023 15:14

Då var det dags att köpa ny softclosepump, igen! Softclosen har spökat en tid till och från, emellanåt funkat klanderfritt långa perioder men nu till slut lagt av helt. Den höll i alla fall 3 och ett halvt år då får man tydligen vara glad. Några rekommendationer var man handlar nytt? Senast köpte jag från Mercedes då kostade den 7700 nu c:a 10´med den usla kronan. Alternativt byta bara den brända motorn om man hittar en sådan. Tacksam för tips!

User avatar
Marie
Guru
Guru
Posts: 6871
Joined: Fri 27 Jun, 2008 11:38
Location: Obervellach bei Hermagor / Kinna

Re: Softcloseproblem.

Postby Marie » Tue 26 Sep, 2023 12:07

Hej Lasse!

I eftertankens belysning så borde du ju justerat frånslagstrycket samma dag som garantin tog slut. Dörrtillslutarpumpen har så vitt jag vet aldrig funnits som piratdel, utan det är Mercedes som gäller. Jag känner en gubbe i Lübeck som låter tillverka elmotorer både till centrallåspumpar och dörrtillslutarpumpar. Han har kontakter i fjärran östern där han får tillverkat dem enligt originalspec.
MB 400SE -92Image
BMW K100RS -85

Ex: MB 200TE -90 (ärvde det rostiga liket 2012)
MB 300SEL -89 (exporterad till Stockholm)
MB 300D Lang -86 (hittade en älg)
MB 200 -85 (smälld av tredje sonen)
MB 240D -80 (rostade bort)

Lasse Bender
Expert
Expert
Posts: 591
Joined: Sun 22 Nov, 2009 22:10
Location: Beddingestrand

Re: Softcloseproblem.

Postby Lasse Bender » Fri 29 Sep, 2023 21:57

Hej Marie!

Det skiljer oerhört i pris mellan dom olika Mercedesåterförsäljarna därav min fråga. T.ex fick jag pris från Landrins i Lund som ville ha 16501 kronor och dessutom hävdade att delen hade utgått!! Kontaktade Ottosons Bil i Tomelilla som fixade hem den på mindre än ett dygn för 9700. Nu är den monterad och hoppas det funkar ett tag. Klockat frånslaget till 3,5 sek. vilket jag tycker verkar lovande.


Return to “W140”

Who is online

Users browsing this forum: No registered users and 2 guests